Back to overview
Maintenance

Scheduled Maintenance: Server Panel

Feb 06 at 08:00pm GMT-5  –  Feb 06 at 09:00pm GMT-5
Affected services
Servers Panel • panel.hycloudhosting.com

Resolved
Feb 06 at 09:03pm GMT-5

The maintenance has been successfully completed.

Updated
Feb 06 at 08:03pm GMT-5

The maintenance period has begun

Created
Feb 06 at 08:00pm GMT-5

We are informing you that the HyCloud server panel will undergo maintenance on the scheduled date.

During this process, we will be performing panel updates, bug fixes, critical bug resolution, and general optimizations to improve system stability and performance.